About

EGLIBC
Mission
Features
FAQ

Download

Repository
Prerequisites

Development

Contributing
Maintainers
Mailing Lists
IssueTracker

Administration

The following content is mainly historical; EGLIBC is no longer maintained or developed except for merges to the remaining active release branches.

You need the tools and patches listed here in order to build EGLIBC.

EGLIBC 2.5 Branch

  • Binutils 2.17 (or later)
  • GCC 4.1.x (or later)
  • Linux 2.6.19.1

On some platforms, additional patches are required:

IA32

This GCC patch fixes problems with unwinding.

PowerPC

These GCC patches fix problems with software floating point.

To debug multi-threaded programs linked with EGLIBC, you need a GDB snapshot created after June 27, 2007 or this GDB patch.