[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [issues] memory leak when invoking openpty

Hi Maxim,

On 04/15/2010 08:37 PM, Maxim Kuvyrkov wrote:
On 4/14/10 1:35 PM, Zhenhua Zhang wrote:

Valgrind reports definitely lost memory leak when I am invoking
openpty(). Could some one help on that?

What is your EGLIBC version?

How do you configure your EGLIBC build?  It seems that you are using
non-default configurations of nsswitch, which exactly option groups are
you enabling or disabling?

I am using eglibc (version 2.10.1-0ubuntu15) on Ubuntu 9.10 with default configuration. I haven't successfully built eglibc 2.10.1 source yet.

I also tried use __libc_freeres to free all memory holds by the C library but it still doesn't work.


My /etc/nsswitch.conf:

passwd:         compat
group:          compat
shadow:         compat

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis